Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Receiving "This file cannot be uploaded properly" message
#1
Hello,

This is my first attempt to use OpenDocMan. I love the concept and am excited about using the product. Here is the problem...

Setup: Windows Server running IIS 7, php 5 mysql 5+
Data dir is located in c:\inetpub and has (to my knowledge) the appropriate rights assignment.

Installation went flawlessly and I have been able to do everything except upload any files. Any attempt to upload returns the following flashing message- "This file cannot be uploaded properly"
I cannot find anything in php logs, IIS logs or any other reason for this behavior.

As a test, I replicated my install steps on a LAMP, and everything was successful. This was a needed data point for me to show the product works. However, the ultimate installation point for the product is the IIS environment.

I am looking for any and all suggestions.

Thanks
#2
That error is coming from the php function "is_uploaded_file" which checks to verify the file was uploaded via a POST method. Sounds like an issue with your server config, or permissions on the folder you server uploads temp files to.
#3
Hi gsawtelle & Stephen,

Did you have any joy in resolving this problem? I am having the same issue on Windows Server / IIS 7 / PHP / MYSQL.

The strange thing is that I had been using version 1.2.7 without issue, now that I have upgraded to version 1.2.9 I receive this error for no apparent reason. I have even created a new database and completed a fresh install of version 1.2.9 and still no joy. There are no errors being produced in the php error log and my directories have the correct write permissions.

I have a WAMP setup in my local enviroment and both version 1.2.7 and 1.2.9 work there without issue.

Thanks
Michael
#4
Stephen, did you have any chance to resolve this for the IIS environment?
I am having the same issue and it seems to be related to the php_fileinfo.dll
#5
I am considering creating a "Filetype Management" option in the site settings that will show "Off", "Filename Extension-Only", and "Mimetype Detection". That way if the system isn't behaving (as many systems do not), it could be turned down, or off.
#6
For me it was a folder protection problem.

In my php.ini file i found the following setting:
upload_tmp_dir=C:\Windows\temp

Once I changed the protections on that specific folder to allow write access to appropriate users I could now add documents again.

Hope this helps someone.

imhemstead Big Grin
#7
I am receiving the same message. 

My system:

Windows XP
WAMP 1.7.3
PHP 5.2.4
MySQL 5.0.45

Served on a localhost.

I have checked the permissions on all of the folders involved and am still having no luck. 

Any and all suggestions are welcomed.
#8
(07-11-2014, 02:20 PM)gsawtelle Wrote: Hello,

This is my first attempt to use OpenDocMan.  I love the concept and am excited about using the product.  Here is the problem...

Setup:  Windows Server running IIS 7, php 5 mysql 5+
 Data dir is located in c:\inetpub and has (to my knowledge) the appropriate rights assignment.

Installation went flawlessly and I have been able to do everything except upload any files.  Any attempt to upload returns the following flashing message- "This file cannot be uploaded properly"
I cannot find anything in php logs, IIS logs or any other reason for this behavior.  

As a test, I replicated my install steps on a LAMP, and everything was successful.  This was a needed data point for me to show the product works.  However, the ultimate installation point for the product is the IIS environment.

I am looking for any and all suggestions.

Thanks

I have exactly the same problem. As far as I know the approeriate users have Write permissions. Have you been able to solve this problem?

Any wuggestions would be apreaciated.

Thanks!


Forum Jump:


Users browsing this thread: 1 Guest(s)