Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
open_basedir restriction in effect
#1
Hi
I have tried to install OpenDocMan using the Softaculous installer from my cpanel. The installation all succeeds, but when i try to go to the ODM page I get a warning:-
is_file() [function is-file]: open_basedir restriction in effecct. File (plug-ins/index.html/index.html_class.php) is not within the allowed path)s)Sad...) in /home/echo/public_html/Plugin_class.php on line 57.
It allows me to log in as administrator, but goes to a page with the same warning and a warning that it cannot modify header information, and the page just has a logo and a link to the OpenDocMan v 1.2.6.2 manual.
Any idea where i go from here?
please?

Justin
#2
Hi
I have the same problem. Installation works fine but after starting the same error message is displayed and I can´t log in as admin.

Is there any help???

Kind regards
#3
I have the same problem too. Please someone has an idea for the solution?

My odm is blocked and noone cant work with.

Sorry for my english.

Pat
#4
Disable open_basedir for your site.
#5
thank for your reponse but where i can disable open_basedir. I have look in my php.ini and there is these lines:

Code:
; open_basedir, if set, limits all file operations to the defined directory
; and below.  This directive makes most sense if used in a per-directory
; or per-virtualhost web server configuration file. This directive is
; *NOT* affected by whether Safe Mode is turned On or Off.
;open_basedir =

I think the option open_basedir is disabled and the problem is already exist.

Can i specifie this option in other place?
An another idea??

thanks
Pat
#6
Put a phpinfo() somewhere in a file to see if open_basedir is truly disabled for your site. I don't think you would be getting that warning if it was disabled.
#7
I have do that in odm dir and y have a line:
Code:
open_basedir    /home/communed:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp    no value

open_basedir is activated??

If yes where and how can i modify that?? I thinked in my php.ini but it was disabled in this file (previous post) and i bon't understand where this option is activated.

Thanks, Pat


Forum Jump:


Users browsing this thread: 1 Guest(s)