Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plug-in: Individual file expiration date
#11
First you need 1.2.6 beta for plugin to work. Best is to install latest trunk from sourceforge.

Those errors you are getting are just deprecated errors, which means that in new versions of php that function will not be supported. Just turn off error warnings in php.
But as I can see those errors have nothing to do with plugin.

Login as ODM admin, change global expiration settings to something like 99999 days, this is way around turning off ODM expiration date settings.

Individual file expiration date is set for every file. For old files go to file, edit and there you will see option for file expiration.
For new file you will se option in add file screen.
#12
i honestly can't find those settings you're mentioning. here are screenies of my test install. i'm using V 1.2.7 so that should be ok, right?

<!-- m --><a class="postlink" href="http://img.photobucket.com/albums/v220/saulrhyz/screeny1.png">http://img.photobucket.com/albums/v220/ ... reeny1.png</a><!-- m -->

<!-- m --><a class="postlink" href="http://img.photobucket.com/albums/v220/saulrhyz/screeny2.png">http://img.photobucket.com/albums/v220/ ... reeny2.png</a><!-- m -->
#13
You are using 1.2.5.7 version. That version doesn't support plugins.
You need 1.2.6 beta version: <!-- m --><a class="postlink" href="http://opendocman.svn.sourceforge.net/viewvc/opendocman/opendocman/trunk/?view=tar">http://opendocman.svn.sourceforge.net/v ... /?view=tar</a><!-- m -->

This is link to sourceforge trunk, latest test version.

After you install this version of ODM, download plugin and follow install instructions in txt file.
#14
woot woot! i think i got it running... still have to test... can anyone explain this error? pls...
[Image: screeny3.png]

2 questions:
1.) what's the alternative to the create Cron job step? i installed ODM in windows with xampp?

2.)also, where do i set the outgoing mail account for odm for it to email notifications on expiring documents?

thank you soooooo much!
#15
Can't help you with error, maybe Stephen can.

If you can't setup cronjob, you can always run it manually. Maybe on windows you can set "schedule tasks", I know you can set it for windows aplications, not sure if you can for php scripts.

You can change outgoing email in index.php, line 47

EDIT: Did you run install.php?
#16
I did, that's the error i got when i ran install.php Sad

thanks for the info on the index! ^_^ will test it now...
#17
done configuring the index file.. also done setting up scheduled task in win xp instead of cron.
i'm confident with the cron job since i'm quite familiar with setting this up. but i have a couple of questions while i was setting up the index.php..

i didn't see there where i was supposed to configure the outgoing email settings? isn't it supposed to email when the document has been authorized? thanks! almost there...
#18
You don't have to configure outgoing email server, it will use local, could be problem with xampp windows instalation.
You can just change email adress which will be in sent/replyto field.
#19
when i tried to run inexp expiration check, i got an error regarding outgoing server smtp, and php.ini? i can't seem to generate the error page again. it was an error in function.mail, line 147 of index.php. any thoughts? this may be the key to solving the outgoing email settings question.

update: was able to generate the error. here's a capture.
[Image: screeny4.png]
#20
The first error you reported is from invalid mysql connection information or a missing database.

The second error is because you need a mail server running on your localhost server, or, configure your PHP.ini to use a different SMTP server.


Forum Jump:


Users browsing this thread: 2 Guest(s)