Community Support for OpenDocMan (Deprecated)
Install problems.... - Printable Version

+- Community Support for OpenDocMan (Deprecated) (
+-- Forum: OpenDocMan Community Discussion (
+--- Forum: OpenDocMan Support - Community Based (
+--- Thread: Install problems.... (/thread-349.html)

Install problems.... - wbhood - 12-09-2010

I have attempted to install the OpenDocMan on both a Windows based server and a Linux based server and I'm getting the same error message on both.

Checking that templates_c folder is writeable... Not writeable - Fix and go Back

I am assuming that I have something in my config.php file wrong, but can't pinpoint it.

I cannot find the templates_c folder anywhere in the included folders with the install - to make it writeable.

Can anyone assist me with this?


Re: Install problems.... - ParsonProject - 12-12-2010

I´ve been reading about this problem, but a cant´t solve.

Paste my config.php:

// Uncomment this one for WINDOWS - Don't forget the trailing backslash "/"
'dataDir' => 'c:/dataDir/',

// Uncomment this one for LINUX - Don't forget the trailing slash "/"
//'dataDir' => '/var/www/document_repository/',

The folder 'dataDir' is located in <!-- m --><a class="postlink" href="fttp://">fttp://</a><!-- m -->

The installation folder for ODM is: <!-- m --><a class="postlink" href="fttp://">fttp://</a><!-- m -->

I don`t understand how to write de name of de 'dataDir'

Thank you.

Re: Install problems.... - wbhood - 12-13-2010

I fixed this issue, but not sure why it needed to be fixed.

The install states the folder templates_c is not writeable. Upon looking through all the folders in the download, there is no templates_c folder anywhere to be found.

So, after two days of editing the config.php file with no success, I simply added the templates_c folder inside the OpenDocMan folder on my web server and re-initiated the install. It worked perfectly.

Not sure why the templates_c folder is not included in the download files and folders.

Re: Install problems.... - catch - 02-02-2013

wow! and 2 years down the road the solution is still the same!
@wbhood: thanks for being persistent - perhaps opendocman would like to thank users like you too?

Re: Install problems.... - Stephen - 02-10-2013

I updated the latest archives to contain the templates_c folder. Not sure how this one slipped through the cracks, but I guess it did.