Community Support for OpenDocMan (Deprecated)
DataDir problem - Printable Version

+- Community Support for OpenDocMan (Deprecated) (
+-- Forum: OpenDocMan Community Discussion (
+--- Forum: OpenDocMan Support - Community Based (
+--- Thread: DataDir problem (/thread-125.html)

DataDir problem - Stephen - 01-13-2010

2006-10-31 04:52:30 PST
This is the message that appear when I try to log the first time:

"There is a problem with your dataDir. Check to make sure it exists and is writeable".

How i can resolve this problem?

2006-11-07 02:11:07 PST

I had this problem too, but I solved it successfully.

You have to look in your 'config.php'.
There is one line, where you have to choose the location of your file repository.
If it exist's and is writable, all must be okay and the script runs perfectly.



2006-12-04 18:17:06 PST
I am receiving this same error. I have checked my config.php and also made sure that the directory is world writable. I am still getting this error. Any thoughts?

2006-12-04 18:23:04 PST
I suppose I should add this: Apache version 1.3.36 (Unix) PHP version 4.3.11 MySQL version 4.0.27-standard

2006-12-20 09:10:40 PST
I got this too. The only way round it that worked for me was to place the file locally and refer to it in config.php as './directoryname'. It looks like my host won't allow me to place reference the file if I place it outside the root.

2007-02-21 12:34:27 PST
I wanted my documents to be under '/home/document_repository'. To put it there it was necessary to change the selinux security context.
Something like 'chcon -R -t httpd_sys_content_t /home/document_repository' (the -R makes it recursive). Not setting this flag will trigger the not writable error on machines running selinux.