Community Support for OpenDocMan (Deprecated)

Full Version: Error!: SQLSTATE[HY000] [1045] Access denied for user 'blabl'@'localhost' (using pass
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is there anyone had a solution for this error? I had installed a opendocman on windows 8.1 and it works fine, I created a database and the username for MYSQL user and password on Phpmyadmin.

These are the steps that I am doing.

1. I unzip the file (opendocman) to the server(localhost) in the www folder
2. I had create a database, mysql database name and password on phpmyadmin
3. Browsing for localhost:8080/opendocuman on any browsers
4. This message appears " Looks like this is a new installation because we did not find a config.php file or we cannot locate the database. We need to create a config.php file now: Create a file...

5. I click on creating a configuration file
6. I just proceed by following the instructions, and to fill out the database name, username (mysql) and password (mysql). I just enter the name of  the database that I already created on the phpmyadmin in the database table. I had import my database from the database.sql
7. When I click next this error appears Error!: SQLSTATE[HY000] [1045] Access denied for user 'testing'@'localhost' (using password: YES) Please make sure you have created a database
8. I go to the config.php file and looking for this error see the code for this file.



config.php - OpenDocMan database config file

Copyright © 2011 Stephen Lawrence Jr.

This program is free software; you can redistribute it and/or

modify it under the terms of the GNU General Public License

as published by the Free Software Foundation; either version 2

of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,

but WITHOUT ANY WARRANTY; without even the implied warranty of


GNU General Public License for more details.

You should have received a copy of the GNU General Public License

along with this program; if not, write to the Free Software

Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.


// Eliminate multiple inclusion of config.php

if (!defined('config')) {

    define('config', 'true', false);

// config.php - useful variables/functions

// ** MySQL settings - You can get this info from your web host ** //

/** The name of the database for [OpenDocMan */

define('DB_NAME', 'test');

/** MySQL database username */

define('DB_USER', 'testing');

/** MySQL database password */

define('DB_PASS', 'password');

/** MySQL hostname */

/* The MySQL server. It can also include a port number. e.g. "hostname:port" or a path to a 

 * local socket e.g. ":/path/to/socket" for the localhost.  */

define('DB_HOST', 'localhost');


 * Prefix to append to each table name in the database (ex. odm_ would make the tables

 * named "odm_users", "odm_data" etc. Leave this set to the default if you want to keep

 * it the way it was. If you do change this to a different value, make sure it is either

 * a clean-install, or you manually go through and re-name the database tables to match.

 * @DEFAULT 'odm_'

 * @ARG String


$GLOBALS['CONFIG']['db_prefix'] = 'odm_';


/** Absolute path to the OpenDocMan directory. */

if (!defined('ABSPATH')) {

    define('ABSPATH', dirname(__FILE__) . '/');


Thank you please help, what I have done wrong.
I had the same problem and I could fix it yesterday. You have to specify which port you are going to use for MySQL, it has to be a free port (3306 is default port but i already used it for another aplication so I tried the 3307 port and worked!). So in the configuration page when you have to put your "Database Host" (its filled with "localhost" by default) you have to complete it like this: localhost:"number of free port for MySQL". eg: localhost:3307. Previously you should have set it up in MySQL configuration. Opendocman looks for a port to obtain MySQL service and one of the reason for your problem is that Opendocman is trying to look for that service in a wrong port. I hope it could be useful for you and good luck. Elias