Community Support for OpenDocMan (Deprecated)

Full Version: MIMETYPE: directory Failed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am running Windows 7, IIS 7.5 and PHP 5.3.2. I installed version 1.3.1 and 1.3.2 of ODM and gives me the exact same error. When I am trying to upload a file (no matter what type) it sends me the following:

MIMETYPE: directory Failed
That file type is not currently supported.<p>Please upload a document conforming to any of the following file types or add the missing MIMETYPE to Admin->Settings->allowedFileTypes:<br><br />Current allowed filetypes:<ul align=left><li>image/gif<li>text/html<li>text/plain<li>application/pdf<li>image/pdf<li>application/x-pdf<li>application/msword<li>image/jpeg<li>image/pjpeg<li>image/png<li>application/msexcel<li>application/msaccess<li>text/richtxt<li>application/mspowerpoint<li>application/octet-stream<li>application/x-zip-compressed<li>application/zip<li>image/tiff<li>image/tif<li>application/<li>application/<li>application/vnd.openxmlformats-officedocument.presentationml.presentation<li>application/vnd.openxmlformats-officedocument.wordprocessingml.document<li>application/vnd.openxmlformats-officedocument.spreadsheetml.sheet<li>application/vnd.oasis.opendocument.chart<li>application/vnd.oasis.opendocument.chart-template<li>application/vnd.oasis.opendocument.formula<li>application/vnd.oasis.opendocument.formula-template<li>application/<li>application/<li>application/vnd.oasis.opendocument.image<li>application/vnd.oasis.opendocument.image-template<li>application/vnd.oasis.opendocument.presentation<li>application/vnd.oasis.opendocument.presentation-template<li>application/vnd.oasis.opendocument.spreadsheet<li>application/vnd.oasis.opendocument.spreadsheet-template<li>application/vnd.oasis.opendocument.text<li>application/vnd.oasis.opendocument.text-master<li>application/vnd.oasis.opendocument.text-template<li>application/vnd.oasis.opendocument.text-web<li>text/csv<li>audio/mpeg<li>image/x-dwg<li>image/x-dfx<li>drawing/x-dwf<li>image/svg<li>application/zip</ul>

I have given all kind of user privileges to the folder IUSR, DeafaultAppPool, etc.. and it is not working. I have also tried some of the posts were I should add the document type but no success. Can you help me? I tried uploading the file into the DEMO website and it worked.

What am I missing?
Thank you in advance.
Wondering why it says "Mimetype: directory" in that message. That will usually display the mime-type, so in this case it seems to be suggesting your server thinks it is a "directory"? Are you uploading a folder somehow?
(02-16-2015, 04:39 PM)adminla Wrote: [ -> ]Wondering why it says "Mimetype: directory" in that message. That will usually display the mime-type, so in this case it seems to be suggesting your server thinks it is a "directory"? Are you uploading a folder somehow?

Hi Stephen, thanks for your quick response.
No I am not selecting a folder. Actually any file I select, returns the same error. 
Would it be possible that my server is receiving the info incorrectly from my ODM installation?
How should I look into how the server is receiving the info?
I think I found a little help to understand the failure mode. I looked at the IIS PHP extensions that were enabled and I tried to see if there was anything there that could of create the problem. I disabled everything but the following:


With these there is no more error but now it shows: THIS FILE CANNOT BE UPLOADED PROPERLY.

If I enable:


The MIMETYPE: Directory Failed error shows up again.
So I think there's might be somthing in this extension that is not working properly.
Any thoughts?

Thank you.
I resolve the problem. The first thing is that the php_fileinfo.dll file that is included in the Windows PHP Installation package has a conflict when installed in Windows 7. To correct it, you need to download the extension only from the PHP site. Once you do that replace the current php_fileinfo.dll in your PHP directory with the current one you just downloaded. I downloaded my copy from:

Secondly I had to provide IUSR user a full access to Windows/Temp folder. If you do not do that the file will never upload and will believe you are trying to upload the TEMP folder which is where all files are stored in the meantime the process is completed.

These two things solved the problem.
Please mark as completed.

Thank you.