Community Support for OpenDocMan (Deprecated)

Full Version: dataDir setting on Windows Server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am running Windows 2008/IIS7 with PHP 5.3.6 and mySQL v5.1. I have Wordpress successfully up and running on this server without any permission issues.

I've installed OpenManDoc and created a directory under the C:\ called docsnforms. Full path is c:/docsnforms. I've given modify permission to both IUSR and IIS_IUSERS as well as the DefaultAppPool user (found it using Procmon.exe). None of these have worked! Maybe I have a syntax error in my config.php file so I'll attach it here. This was a brand new install and I went with the 1.2.6Beta. My config.php file seems quite a bit shorter than most posted here.

Any help would be appreciated!

config.php - OpenDocMan database config file
Copyright (C) 2011 Stephen Lawrence Jr.

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.

// Eliminate multiple inclusion of config.php
if( !defined('config') )
    define('config', 'true', false);

// config.php - useful variables/functions

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for [OpenDocMan */
define('DB_NAME', 'opendocman');

/** MySQL database username */
define('DB_USER', 'admin');

/** MySQL database password */
define('DB_PASS', 'Prime+1');

/** MySQL hostname */
define('DB_HOST', 'localhost');
global $CONFIG; $CONFIG = array(
* Prefix to append to each table name in the database (ex. odm_ would make the tables
* named "odm_users", "odm_data" etc. Leave this set to the default if you want to keep
* it the way it was. If you do change this to a different value, make sure it is either
* a clean-install, or you manually go through and re-name the database tables to match.
* @DEFAULT 'odm_'
* @ARG String
'db_prefix' => 'odm_',
'dataDir' => 'c:/docsnforms/',


/** Absolute path to the OpenDocMan directory. */
if ( !defined('ABSPATH') )
        define('ABSPATH', dirname(__FILE__) . '/');
Is that a 1.2.6 config? It looks like you have changed it.

Check your config-sample.php, the bottom of your config is wrong (and also contains an extra comma). Was there documentation that told you to add the dataDir to the config.php file? Just curious if there is an old doc that I need to update.

The dataDir setting is now handled in the database through the Admin->Edit Settings page.

Weird, I didn't get an email telling me I had a reply here. Thanks for info. I did change it because all the posts I was reading said to. I added the "array" part. thought I had it copied correctly. So I should go back to the original config file and change the dataDir in the database? I didn't find ANY documentation that pointed me in that direction.


Got it! I changed the bottom of the config file to match the config-sample.php. Then I went into the database and found the settings table, updated the dataDir field with the path to my directory and VOILA!!!! I'm in! Thanks.