Community Support for OpenDocMan (Deprecated)

Full Version: Cannot check document back in
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi All,

I installed Opendocman a few days ago and initially had issues installing and setting it up but thats all sorted now (with help from Steve).

The problem I now have is strange, i can upload a document ok, I can check a document out ok, but when i go to check the document back in i get to select the file and enter a comment for changes but when i click Check-In i get a 404 error and the file remains checked out.

Any ideas?

Ok figured it out, the document i originally uploaded had a space in the filename "test document.txt", when i checked the file out and downloaded it Opendocman put an Underscore in the place of the space "test_document.txt", I edited the document and checked it back in with the name that OpenDocman gave it "test_document.txt" and get the 404 error, i removed the underscore from the file name and put the space back "test document.txt" and i was able to check the file in with no problems.

Just tested this and confirmed this is the issue.
Can you duplicate this on our live demo?
It behaves differently on the demo, i just tried it, when I check out and download the document on my setup it replaces the space with an underscore, on your system it doesn't.

As long as the filename is the same the check in works, but if the reviewer/editor tries to check the document in with the underscore if will fail and you get a page not found 404 error.

And on your test system it says "Error: wrong file! Please check in the right file" on my system it does not.

So, to summarise from that ramble, something on my system does not like spaces in the file names and replaces then with underscores and Opendocman does not tell me it's the wrong file, it just gives a page not found error.
This older post talks about the same issue. If I remember, there was something going on with IE:

<!-- l --><a class="postlink-local" href="">viewtopic.php?f=4&t=67&p=118&hilit=underscore#p118</a><!-- l -->
Yup, that looks to be the same issue, is there going to be a resolution to this, or do i just have to put up with it?
Try the 1.2.6 beta demo site:

<!-- m --><a class="postlink" href=""></a><!-- m -->
Ok tried the 1.26 demo site and thats ok. (just upgraded to IE9)

The 1.25 demo site still has issues though, uploaded "test document.txt", checked it out (downloaded as "test document.txt"), tried to check it it as "test document.txt" and it failed saying "Please Upload a valid document", and trying to check in "test_document.txt results in "Error: Wrong file! Please check in the right file".

I would really really like a solution to this as its preventing me from implementing this great piece of software as I would wish.

How long until the 1.26 is out of beta?
Just installed 1.26 on my server here and it has some of the same issues.

The space in the filename is not an issue any more.

But if i try to check in a different document than the one i checked out i get a 404 error, instead of the Incorrect file dialog.....

Any ideas?
Here is the bug that is fixed in 1.2.6: <!-- m --><a class="postlink" href=""></a><!-- m -->

As for the beta, I was getting ready to release it to the public and was performing some performance test and found a major issue with the main file list function that was causing slowdowns when there were over a few hundred files in the list.

I have improved the performance quite a bit but due to my limited time availability currently I am not sure when 1.2.6 will be released.
Yup, the space/underscore bug in no longer an issue with 1.26, the only issue I have with it now is the 404 when checking in a document with a different name by mistake.
Pages: 1 2