Community Support for OpenDocMan (Deprecated)

Full Version: newbie question
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Dear all,
Recently i just downloaded the opendocman, i'm planning to install on linux server.
i did :
1. Download opendocman
2. Copy to a folder in linux server
3. Extract file
4. copy to my web server document root directory which is : /var/www/html/opendocman/
5. But when i access by using ie, i got a message :

You don't have permission to access /opendocman on this server.

what did i do wrong..?
anyone could help me out on this..?
Thank You,
Edward i can access the page, but when in installing error like this :
unable to connect Access denied for user "opendocman"@"localhost" ( Using password: YES )
what should i do..?
please help Sad

I add my screenshoot on attchment.
okay, after i edit line in config.php :
root_username => admin

when i refresh the page, and now it keeps installing...
and its already almost over 20mins.
ok now is finished installing, but another problem happened.
the dataDir is problem, cannot located the data directory,
please see my config.php
Okay now i can login and access the main page of opendocman.
I tried to :
1. Add user...OK
2. Add Dept...OK
3. Upload documents..OK
4. Approved the document by admin...OK
5. But when i tried to download or view, it gives error : " file doesn't exists"

Anyone can help me...?
not sure about your problem, but looking at your 'config.php' I'd assume, the path to your 'dataDir' may be not correct (relative/absolute), what about trying to set up it this way (worked for me just fine):

// Uncomment this one for LINUX - Don't forget the trailing slash "/"
'dataDir' => '/var/www/document_repository/',

otherwise, there are some threads referring to the same / similar problem in the forums here, you may find an answer there...
hi bit2bit...
the dataDir is okay now,
i success upload a file to opendocman, but when i want to view the file from opendocman, it gets error : file does not exists
could you help me out..?

hi there! can you have a look at your //var/www/document_repository directly please:

* are there any files stored?
* what is the size of these files?
* what permissions do that files have?
* what permission does your 'document_repository'-dir have?

sorry, i dont have gui.
I only console :p
When i opened the directory, the files are exists.
I am already set the chmod 777 to all the files, but still cannot access.
this is shown when i tried to deleted a file :
"Last Message: Could not create /var/www/html/opendocman/dataarchiveDir/"
how come theres a dataarchiveDir..?
my dataDir is: /var/www/html/opendocman/data
Pages: 1 2 3