Community Support for OpenDocMan (Deprecated)

Full Version: file does not exist, but able to dl after checking out & in
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2

Thank you for the great software. I really love it.

I am having a problem currently, and have been trying to solve it. I have tried uninstalling everything, removing the databases, and the directories, but still I am have the problem.

After uploading the file, the file size remain as "x", and when I try to open the file, it says it does not exist. I have tried with and without secure url, authorisation and such. When I check out the file, and try to check in again (even though after check out it says the file does not exist), I am able to upload the same file. The file size shows up and I am able to read and download the file.

I would appreciate if anyone can help solve the problem. Big Grin

What version are you using?
I am using OpenDocMan v1.2.5.7, auto install using Softaculous on my site. Thanks for your help!
Let me know if you can duplicate this issue on our demo server at <!-- m --><a class="postlink" href=""></a><!-- m -->



If you cannot, then it is more than likely a server configuration issue, or an opendocman configuration issue.

let me know what you find.
The upload was successful on the demo. So do you know how I can fix this issue?
It seems like a permissions issue. Where is your dataDir configured to?

Have you talked to the script people?
Erm.. who are the scripts people? You mean softaculous? They don't provide support. It comes with the website hosting.

I am a bit confused why the file will appear after check in and check out, but not in the initial upload. If it is the data dir issue, correct me if i am wrong, the file will not be uploaded even after check in and check out. So I am not sure what is happening actually.
Also, I have enabled 777 for the data dir. I have tried the roots directory, something like /home/xxx/www/xxx/document_depository. I have also tried <!-- m --><a class="postlink" href=""></a><!-- m -->. I have enabled 777, for both the directories, yet the same issue happens. Sad
Ok, to check things, do an upload of a file, then see what the permissions are on that file after the upload when it is failing. Then check-out/check-in the file and compare the permissions and see if they are identical. That is a good start.
I have exactly the same problem. File uploads with X file size if you check out the file you get
"file does not exist2

but then if you go to check in, the file is showing you check it in and I then get the following errors
Warning: fopen(/home/wagdocli/WAG_docs5.dat) [function.fopen]: failed to open stream: No such file or directory in /home/wagdocli/public_html/opendocman/check-in.php on line 210

Warning: filesize() [function.filesize]: stat failed for /home/wagdocli/WAG_docs5.dat in /home/wagdocli/public_html/opendocman/check-in.php on line 211

Warning: fread(): supplied argument is not a valid stream resource in /home/wagdocli/public_html/opendocman/check-in.php on line 211

Warning: fclose(): supplied argument is not a valid stream resource in /home/wagdocli/public_html/opendocman/check-in.php on line 212

If you then log back in the document is there and can be read ok
Pages: 1 2