Community Support for OpenDocMan (Deprecated)

Full Version: Corrupt files after download (Checkout)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I've tried to Check out Word & Excel (Office 2007 and older formats, doc, docx, xls) files, they view ok, but after I check them out, they are corrupt on the local drive.

I'm not sure I have the correct mime settings in either my PHP config or the mime file in Apache.

Has anyone has the same issue ?

Environment: Windows XP SP3, latest Opendocman, Word 2007


I installed today the last version I have the same problemm.
After looking into the original file and the checked out file I noticed that in the checked out file the was 1 byte more then the original file at the beginning off all the files that I checked out there is a space inserted.
I don't now how this happens but as this problemm is not frequently reported I suspect is has something to do with the environment it runs ons.
I am going to install it on a different environment and check it again.

I installed it today on a other web server and it runs without any problemm must be a problemm related to the web server.
Nobody a idea ?
First time I have heard of something like that.
The funny thing is if you use the [Download] button the Microsoft documents open fine.

I've got the same problem.
I have OpenDocman V1.2.7.2 running on the standard apache webserver that comes with the Synology DS241+ (NAS)
When I upload f.i. a msword-document to the server, the document gets stored as a "<number>.dat" file.
When I rename that file to <number>.doc and open this document in msword everything is okay. The document is the same as the original and is readable.

On the other hand, when I check this document out of OpenDocman via the interface and store this document as a ".doc" file, there seems something wrong.
The document won't open in ms-word.
When I open this document in the text-editor Ultra-edit in hexadecimal mode, I noticed that an extra space-character was added at the beginning of the
document. When I removed this character, the document could again be opened in ms-word.

Not only at word-documents but with all checked-out documents, an extra space-character wass added at the beginning of the document.

I tried the latest development version of OpenDocman with no luck.
I also tried the webserver of my provider, with the same results.

So there is nothing wrong with the webserver on my Synology NAS, because the webserver of my provider worked the same.

Has anyone an idea what could be the cause of this and maybe could com up with a solution please?
Can you duplicate this issue on our demo site? <!-- m --><a class="postlink" href=""></a><!-- m -->
I duplicated the issue on the demo-site.
But the problem did not appear.
We do have the same version of docman.
Which webserver is running on the demo-site?
I assume you meant to say you tried to duplicate the issue on the demo site but couldn't.

The demo site is running apache.

Have you tried to re-install from scratch? I don't see how a space could be added to a file, but I have seen stranger things. Maybe you have a space typed in somewhere that shouldn't. Is your installation customized at all besides the config.php file?

spammie Wrote:I duplicated the issue on the demo-site.
But the problem did not appear.
We do have the same version of docman.
Which webserver is running on the demo-site?
If you look at topic: <!-- l --><a class="postlink-local" href="">viewtopic.php?f=4&t=616</a><!-- l --> the same problem was described.
The pdf-file was uploaded to the server. The file stored on te server could be opened.
After checkout, the pdf-file was not readable.
Also in this topic nobody came up with a real solution.
Pages: 1 2