Community Support for OpenDocMan (Deprecated)

Full Version: Cant add any user defined fields
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there, my install of opendocman works great except when adding user defined fields, i go through the process and try to add, pick the table and then give it a display name and then click add user defined field.
It states succesful but nothing appears, also i can only drop down pick list... i've gone all over the forum and website and cannot find the patch that is mentioned...

any idea's?
Hi all,

I'm having the same problem. I'd like to add more more browseable fields besides "Author, Department, and File Category." Can someone let me know if User Define Fields a way to achieve this, or if such a thing isn't really possible?

I'm sure i must be missing something, i've gone through all the possilbilities and still can't work it out..... anyone?

UDF support is limited to pick list at this time. Also, can you try out our demo server and see if you can duplicate the issue there?

I just tried the demo; I did have the same issue. I try entering a new field, but none appears and nothing is added to the 'delete' menu. I've tried making up a Table name and using a Table name taken from OpenDocMan's database (such as 'data').

Any ideas?
It's a bug. I will work on it in the AM.
I have updated the latest SVN 1.2 branch to include fixes for this issue.
Thanks! But I encountered a problem. I found revision 692, and saw that four files had changed - two install files and udf.php and udf_functions.php. Since I've already installed, I guess I only need the last two? So I downloaded them and replaced my versions with these new versions.

(As the above probably makes clear, I don't really know what I'm doing.)

But now when I log in, I get this error:

Warning: Cannot modify header information - headers already sent by (output started at /var/www/opendocman/udf_functions.php:274) in /var/www/opendocman/index.php on line 89

Any ideas?
#Sorry for a double post
#My status don't say anything about 'pending post'
#Just to make sure
#And forgot to say THANKS to STEVE!

Upgrade went well from ->

Warning: mysql_fetch_row() expects parameter 1 to be resource, boolean given in C:\xampp\htdocs\xampp\odm1257\udf.php on line 356,
also on lines 358, 377 and 384. */

@spbitticks; here is what i did:

1. I copied all the files in the link (the rev 692)
(<!-- m --><a class="postlink" href=""> ... nches/1.2/</a><!-- m -->) using a download manager took me < 2 minutes.
2. Pasted in C:\xampp\htdocs\xampp.
3. Edited config_local.php
4. Open firefox, typed <!-- m --><a class="postlink" href="http://localhost/odm1257/install">http://localhost/odm1257/install</a><!-- m -->
5. Upgraded.
@umbraimago - So your you have a working UDF now? I wasn't sure if you were saying it works, of if you had a problem. Smile
Pages: 1 2