Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
dataDir missing
#1
Hi, I'm new to OpenDocMan, I did a fresh install and afterwards it keeps saying:
"There is a problem with your dataDir setting. It does not appear to exist."
although the "data" dir does exist and have the write permissions.
that is my config.php code:
Code:
<?php
/*
config.php - OpenDocMan database config file
Copyright (C) 2011 Stephen Lawrence Jr.

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
*/

// Eliminate multiple inclusion of config.php
if( !defined('config') )
{
    define('config', 'true', false);

// config.php - useful variables/functions

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for [OpenDocMan */
define('DB_NAME', 'filaManager');

/** MySQL database username */
define('DB_USER', 'yaron');

/** MySQL database password */
define('DB_PASS', 'yaronsit');

/** MySQL hostname */
define('DB_HOST', '127.0.0.1');

/**
* Prefix to append to each table name in the database (ex. odm_ would make the tables
* named "odm_users", "odm_data" etc. Leave this set to the default if you want to keep
* it the way it was. If you do change this to a different value, make sure it is either
* a clean-install, or you manually go through and re-name the database tables to match.
* @DEFAULT 'odm_'
* @ARG String
*/
$GLOBALS['CONFIG']['db_prefix'] = 'odm_';

/*** DO NOT EDIT BELOW THIS LINE ***/



/** Absolute path to the OpenDocMan directory. */
if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
}


What should I do?

Thanks in advance,
Kadosh1000
#2
I just went through this problem in the very next post on this forum! Apparently with v1.2.6 you have to set the dataDir path in the database. It's in the settings table.

Once you do that, you should be able to open the home page again, login and be presented with your setup options.

This is of course assuming that you've already set your dataDir with the correct permissions for the platform you're on. I am on Windows server, so I gave IUSR and IIS_USR modify permissions on it.

Good luck!
#3
kadosh1000,

During the installation you should have filled out the form that asked for you dataDir location. Did you perform a manual installation?
#4
I downloaded v1.2.6 and unzipped it in the directory on the web server per the instructions. I then manually edited the config-sample.php file to enter all my database info and saved it as config.php. Next created a folder in the root of C: for my dataDir directory and gave it permissions. Then I was ready to open a browser and try and go to <root domain>/<openmandoc directory>/install so for me that was <!-- m --><a class="postlink" href="http://bert.redcanoecu.com/forms/install">http://bert.redcanoecu.com/forms/install</a><!-- m --> then I hit enter and got the login page with the error that my dataDir was missing. I never got presented with the setup page.

It wasn't until I used phpMyAdmin to connect to the openmandoc database and manually change the field for the path to the dataDir that I got presented with that page to setup stuff. It was an interesting install.
#5
russ668,

Here are the installation steps listed in the opendocman.txt file. There is no need to create the config.php file unless you are doing a manual install. Please verify you have followed these steps.:

Quote:2.2 New Installation

1. Untar/Unzip files into any dir in your webserver documents dir

2. Create a MySQL database/username/password.

3. Make a directory for the files to be stored that is accessible
to the web server but not available by browsing. Ensure the
permissions are correct on this folder to allow for the web
server to write to it

ex. $>mkdir /usr/local/opendocman/data

4. Load the opendocman page in your web browser
(ex. <!-- m --><a class="postlink" href="http://www.example.com/opendocman/">http://www.example.com/opendocman/</a><!-- m --> ) and follow the prompts.

5. Login as "admin" (with the password you set during the installation).

6. Edit your site settings at Admin->Site Settings

7. Add departments, categories, users, etc.

8. Enjoy!
#6
Good time of the day,
I have the same problem: "There is a problem with your dataDir setting. It does not appear to exist.". I spend all day trying to resolve it and no result. I did automatic installation, manual, I change the path directly in database table - no result.
It seems to me that I do not understand correctly how to define this directory on server and how to show it path to opendocman.
When i login to my part of internet provider server, I see the following structure:
imap
domains
mydomen.eu
public_ftp
Public_html
I tried to make a data directory inside mydomen.eu and also inside Public_html - doesn't helped!
I give to datadir all possible permissions to be read, right and execute for everybody - not worked.
I tried to write path to datadir in the DB table by 2 different ways:
1. <!-- m --><a class="postlink" href="Http://mydomen.eu/odm_data">Http://mydomen.eu/odm_data</a><!-- m -->
2. /home/user/domains/mydomain.eu/odm_data
Something is wrong.
Could somebody please give me detailed instruction how to create right data directory?

I have not access to executing commands directly on server - my provider give to all users access through DirectAdmin.

Serge
#7
dataDir is path, not a URL, so #2 would be the way you would enter it on a Linux server.

During the installation, OpenDocMan checks your dataDir value on the server and runs the "is_dir" command. If it returns with an error, then it is not finding a directory with that name at that location.

Is this being installed on a Windows server?

steve
#8
it looks like your error is coming from the main program, not the installer. Did you install 1.2.6.1 successfully and then received this message when you tried to login?

Steve
#9
This problem is solved:
there was 2 errors in installation - the path to dataDir was shown incorrectly (in short form) and in the DB table I occasionally tried to write path to field name, not value.
The correct path syntaxes was /home/user/domains/mydomain.eu/public_html/odm_data/
Now it seems to be work.

BUT! I find 2 new problems ...

1. I have not access to site settings - there is now menu as admin - settings, only admin. So, I can only administrate users, department and categories.
2. Tried to upload some files and discover, that pdf files give an error message (in message itself pdf is listed as available for upload). I did the same on live demo and result was the same - pdf gives an error.

Should I open a new topic to discuss these matters?

i installed version 1.2.6.1, downloaded yesterday.
Serge
#10
There is a "root_id" value in the odm_settings table that determines which userID is the "root" user. Only that user can edit the site settings.

For your other issue, you should see some message telling you which mime type was rejected. You can add that file type using the file type editor as the root user.

steve


Forum Jump:


Users browsing this thread: 1 Guest(s)