Community Support for OpenDocMan (Deprecated)
error starting after install - Printable Version

+- Community Support for OpenDocMan (Deprecated) (
+-- Forum: OpenDocMan Community Discussion (
+--- Forum: OpenDocMan Support - Community Based (
+--- Thread: error starting after install (/thread-56.html)

error starting after install - Stephen - 01-13-2010


2008-08-07 12:04:14 PDT
I have downloaded and installed, run install to create the MYsql database but when I try and launch Opendocman i get the following

Parse error: syntax error, unexpected T_STRING, expecting ')' in C:\opendocman\config.php on line 18

I have checked config.php, function.php & version.php but cant find any mis-matched brackets.

please help


2008-08-07 12:05:57 PDT
sorry extra info

win 2003
abyss web server
php 5

also tried IIS and get the same result



2008-08-07 12:30:50 PDT
What is on line 18 of config.php ?

If I look at my version, it is part of the GPL comments.

2008-08-08 00:37:20 PDT
assuming that comment lines are ignored when parsing its in the middle of the global array definition

2008-08-11 05:56:01 PDT
You can't really "ignore" comment lines... you ignore the contents of the comments, but the PHP engine still has to parse the line terminators, and end of comment tags. The PHP engine also needs to parse the various HTML tags too. I can only reflect on my experiences with Linux-based PHP implementations, but the line numbers in error messages have always referenced the actual line number of the pre-parsed file. It would be really hard to debug code if you had to manually calculate the Nth line of code. If your PHP engine is only counting non-comment lines, then debugging will be less than fun.

I was able to duplicate your error by removing a comma (",") from the end of one of my lines in config.php. The line number in the error message referenced the next non-comment line of code. This makes sense, since the PHP engine didn't know the comma was missing until it found something else.

If you post a copy of your config.php it might help us debug your issue.

2008-08-11 12:55:09 PDT

managed to track it down to an extra */ at the end of the $global array declaration. I have another issue but will post separately.

thanks for the reply